Простейший HTTP GET запрос с параметрами

Готовые тексты модулей и решений
Ответить
Аватара пользователя
admin
Администратор
Сообщения: 71
Зарегистрирован: 06 июл 2017 09:26

Простейший HTTP GET запрос с параметрами

Сообщение admin » 05 ноя 2018 03:55

Код:

Код: Выделить всё

&НаСервере
Процедура ПолучитьДанныеНаСервере()
	ПараметрыЗапроса=ОбщийМодульСервер.СоздатьТаблицуПараметровЗапроса();
	ОбщийМодульСервер.ДобавитьПараметр(ПараметрыЗапроса,"key",Объект.Ключ);
	ОбщийМодульСервер.ДобавитьПараметр(ПараметрыЗапроса,"inn",Объект.ИНН);

	Соединение = Новый HTTPСоединение("yandex.ru",,,,,30,Новый ЗащищенноеСоединениеOpenSSL());
	ТекстЗапроса="/api3/req?";
	
	Для Каждого Стр Из ПараметрыЗапроса Цикл
		Если ПараметрыЗапроса.Индекс(Стр)=0 Тогда
			ТекстЗапроса=ТекстЗапроса+Стр.Параметр+"="+Стр.Значение;
		Иначе
			ТекстЗапроса=ТекстЗапроса+"&"+Стр.Параметр+"="+Стр.Значение;
		КонецЕсли;
	КонецЦикла;
	Запрос = Новый HTTPЗапрос(ТекстЗапроса);
	Ответ = Соединение.Получить(Запрос);
	Если Ответ.КодСостояния = 200 Тогда
	    ТестОтвета=Ответ.ПолучитьТелоКакСтроку();            
	Иначе
	    Сообщить("Сервер временно недоступен, код ответа: "+Ответ.КодСостояния);     
	КонецЕсли;
КонецПроцедуры
Текст модуля "ОбщийМодульСервер":

Код: Выделить всё

Функция СоздатьТаблицуПараметровЗапроса() Экспорт
	ПараметрыЗапроса=Новый ТаблицаЗначений;
	ПараметрыЗапроса.Колонки.Добавить("Параметр");
	ПараметрыЗапроса.Колонки.Добавить("Значение");
	Возврат ПараметрыЗапроса;
КонецФункции

Процедура ДобавитьПараметр(знач Таблица, Параметр, Значение) Экспорт
	 СтрокаТаблицы=Таблица.Добавить();
	 СтрокаТаблицы.Параметр=Параметр;
	 СтрокаТаблицы.Значение=Значение;
КонецПроцедуры

Ответить

Кто сейчас на конференции

Сейчас этот форум просматривают: нет зарегистрированных пользователей и 0 гостей