1С переместить файлы из тома на диске в базу

Готовые тексты модулей и решений
Ответить
Аватара пользователя
admin
Администратор
Сообщения: 83
Зарегистрирован: 06 июл 2017 09:26

1С переместить файлы из тома на диске в базу

Сообщение admin » 03 май 2020 22:59

Код: Выделить всё

&НаСервере
Процедура СтартНаСервере()
	Для Каждого спр из Метаданные.Справочники цикл
		Если Не стрнайти(спр.Имя,"ПрисоединенныеФайлы") =0 Тогда
			Выборка=Справочники[спр.Имя].выбрать();
			Пока Выборка.Следующий() цикл
				Если выборка.ТипХраненияФайла=Перечисления.ТипыХраненияФайлов.ВТомахНаДиске Тогда
					//Ф=Новый Файл(выборка.Том.ПолныйПутьWindows+выборка.ПутьКФайлу);
					Ф=Новый Файл("\\SRV\ExtFiles\"+выборка.ПутьКФайлу);
					Если ф.Существует() Тогда
						обж=выборка.Ссылка.ПолучитьОбъект();
						обж.ТипХраненияФайла=перечисления.ТипыХраненияФайлов.ВИнформационнойБазе;
						обж.Размер=ф.Размер();
						обж.Записать();
						НЗ=РегистрыСведений.ДвоичныеДанныеФайлов.СоздатьНаборЗаписей();
						НЗ.Отбор.Файл.Установить(обж.Ссылка);
						СтрокаНЗ=НЗ.Добавить();
						СтрокаНЗ.Файл=обж.Ссылка;
						СтрокаНЗ.ДвоичныеДанныеФайла=Новый ХранилищеЗначения(Новый двоичныеДанные("\\SRV\ExtFiles\"+выборка.ПутьКФайлу));
						нз.Записать(истина);
					конецесли;
				КонецЕсли;	
			конеццикла;
		КонецЕсли;
	конеццикла;
	сообщить("готово");
КонецПроцедуры

Ответить

Кто сейчас на конференции

Сейчас этот форум просматривают: нет зарегистрированных пользователей и 1 гость