1С БСП СКД переопределение настроек отчета

Готовые тексты модулей и решений
Ответить
Аватара пользователя
admin
Администратор
Сообщения: 83
Зарегистрирован: 06 июл 2017 09:26

1С БСП СКД переопределение настроек отчета

Сообщение admin » 23 апр 2020 15:50

Перестаньте править БСП!!!!!
Вы вывели отбор подразделений на форму списком, а список только для чтения, а вы можете проставить галочки, то вот пример как для конкретного отчета переопределить список подразделений для выбора.
Конфигурация 1С:ERP Управление предприятием 2 (2.4.9.82)

Пишем в модуле отчета:

Код: Выделить всё

Процедура ПриОпределенииПараметровВыбора(Форма, СвойстваНастройки) Экспорт
	Если ПолучитьФункциональнуюОпцию("ИспользоватьПодразделения") 
		И СвойстваНастройки.ОписаниеТипов.Типы().Количество() = 1
		И СвойстваНастройки.ОписаниеТипов.СодержитТип(Тип("СправочникСсылка.СтруктураПредприятия")) Тогда
		СвойстваНастройки.ЗапросЗначенийВыбора = ЗапросДляОтбораПодразделение();
		СвойстваНастройки.ОграничиватьВыборУказаннымиЗначениями = Ложь;
	КонецЕсли;	
КонецПроцедуры

Процедура ОпределитьНастройкиФормы(Форма, КлючВарианта, НастройкиОтчета) Экспорт
	 НастройкиОтчета.События.ПриОпределенииПараметровВыбора=истина;
КонецПроцедуры

Функция ЗапросДляОтбораПодразделение()
	Запрос = Новый Запрос;
	Запрос.Текст = "ВЫБРАТЬ РАЗРЕШЕННЫЕ
	               |	СтруктураПредприятия.Ссылка КАК Ссылка
	               |ИЗ
	               |	Справочник.СтруктураПредприятия КАК СтруктураПредприятия
	               |ГДЕ
	               |	СтруктураПредприятия.Родитель.Код = ""000000190""
	               |
	               |УПОРЯДОЧИТЬ ПО
	               |	СтруктураПредприятия.Наименование";
	
	Возврат Запрос;
КонецФункции
Процедура "ОпределитьНастройкиФормы" вызывается из любого отчета в попытке из модуля, в ней мы включаем запуск процедуры из модуля "ПриОпределенииПараметровВыбора" (есть еще глобальная в БСП, но нам хочется доработать только наш отчет, из глобального процедуры забираем код и редактируем его (в нашем случае запрос), сначала отработает глобальная процедура, затем наша, только для нашего отчета.
Отладчиком и стеком вызова можно увидеть очень много других настроек, которые можно изменить без правки БСП.


https://infostart.ru/public/1227893/

Ответить

Кто сейчас на конференции

Сейчас этот форум просматривают: нет зарегистрированных пользователей и 1 гость