Найдено 75 результатов

admin
06 янв 2020 18:15
Форум: Готовые листинги и решения
Тема: 1с правильный вывод табличного документа на печать
Ответы: 0
Просмотры: 239

1с правильный вывод табличного документа на печать

Если Не ОбщегоНазначенияКлиент.ПодсистемаСуществует("СтандартныеПодсистемы.Печать") Тогда Возврат; КонецЕсли; ИдентификаторПечатнойФормы = "СписокОшибокПриЗагрузкеExcel"; НазваниеПечатнойФормы = НСтр("ru = 'СписокОшибокПриЗагрузкеExcel'; |en = 'Cut card'"); МодульУправлениеПечатьюКлиент = ОбщегоНаз...
admin
06 янв 2020 18:11
Форум: Готовые листинги и решения
Тема: 1с чтение из Excel без его установки (Microsoft ADODB)
Ответы: 0
Просмотры: 253

1с чтение из Excel без его установки (Microsoft ADODB)

украденная функция из интернетов и допиленная под себя: // Метод "Microsoft ADODB"/ // // Параметры: // ФайлEXCEL - Полное имя файла (путь к файлу с именем файла и расширением). // ИмяЛиста - Имя выбранного листа файла EXCEL. // СтрокаЗаголовка (по умолчанию = 1) - Номер строки EXCEL, в которой расп...
admin
30 сен 2019 00:14
Форум: Windows
Тема: Анализ wifi сетей
Ответы: 0
Просмотры: 1565

Анализ wifi сетей

бесплатная утилита
https://insssider.com
admin
10 авг 2019 16:16
Форум: Наши услуги
Тема: Разработка, доработка и поддержка конфигураций на базе платформы 1С 8.х
Ответы: 1
Просмотры: 2743

Re: Разработка, доработка и поддержка конфигураций на базе платформы 1С 8.х

Увеличился персонал, работаем удаленно, для потенциально крупных проектов осуществляем выезд по Москве и МО.
Ставка 1700 руб\час
Так же готовы рассматривать проектную деятельность.
admin
09 авг 2019 14:33
Форум: Готовые листинги и решения
Тема: Получить уникальный идентификатор из "Объект не найден...."
Ответы: 0
Просмотры: 2094

Получить уникальный идентификатор из "Объект не найден...."

Функция ПолучитьGUIDпоОбъектНеНайден(ГУИДУдОбъкта) ГУИДУдОбъктаСтр = СтрЗаменить(ГУИДУдОбъкта,"<Объект не найден> (",""); ГУИДУдОбъктаСтр = СтрЗаменить(ГУИДУдОбъктаСтр,")",""); ГУИДУдОбъктаСтр = СтрЗаменить(ГУИДУдОбъктаСтр,"0x",""); ГУИДУдОбъктаСтр = Сред(ГУИДУдОбъктаСтр, Найти(ГУИДУдОбъктаСтр,":")...
admin
09 авг 2019 14:31
Форум: Готовые листинги и решения
Тема: Получить таблицу значений из макета
Ответы: 0
Просмотры: 1686

Получить таблицу значений из макета

Функция ПолучитьТЗИзМакета(ТабДок, КолонкаИндекса = 1) Экспорт ТаблицаДанных = Новый ТаблицаЗначений; НомерКолонки = 0; Пока Истина Цикл НомерКолонки = НомерКолонки + 1; ИмяКолонки = ТабДок.Область(1, НомерКолонки).Текст; Если ПустаяСтрока(ИмяКолонки) Тогда Прервать; КонецЕсли; ТаблицаДанных.Колонк...
admin
01 авг 2019 14:33
Форум: Готовые листинги и решения
Тема: 1С УФ Быстрый отчет СКД программно
Ответы: 0
Просмотры: 876

1С УФ Быстрый отчет СКД программно

кидаем табличный документ на форму (ВыводТопаОшибок) кидаем кнопку рисуем макет скд (ТопОшибок) на сервере: ДанныеРасшифровкиРезультат = Новый ДанныеРасшифровкиКомпоновкиДанных; СКДРезультат = РеквизитФормыВЗначение("Объект").ПолучитьМакет("ТопОшибок"); URLСхемы = ПоместитьВоВременноеХранилище(СКДРе...
admin
14 июл 2019 08:13
Форум: Готовые листинги и решения
Тема: Программно создать страницу, табличное поле, командную панель, колонки табличного поля (обычное приложение)
Ответы: 1
Просмотры: 750

Re: Программно создать страницу, табличное поле, командную панель, колонки табличного поля (обычное приложение)

навесим процедуру при изменении на созданную колонку

Код: Выделить всё

НоваяКолонка.ЭлементУправления.УстановитьДействие("ПриИзменении",Новый Действие("ааб_ПриИзмененииКоличества"));

далее:

Код: Выделить всё

Процедура ааб_ПриИзмененииКоличества(Элемент)
	  Сообщить("При изменении количества");
КонецПроцедуры